Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 08, 2026 - 20:00 EDT
Scheduled
We will be performing a database performance upgrade. It is only expected to result in 2-5 minutes down time during the allotted hour of maintenance however, we cannot determine when during that time it will happen. No work will be lost and you can continue using the system as you always would. You will likely need to log in again once the upgrade is complete.
Posted Apr 08, 2026 - 16:57 EDT
This scheduled maintenance affected: Gambit ID Check (Gambit ID Check (Production - AWS Canada Cloud) Application).